Fetch 5.8 for cs008

The previous version of Fetch was 32bit and does not support the newest macOS Catalina (version 10.15.x). Fetch version 5.8 is compatible with Macs running macOS 10.13 High Sierra and later.

You can download and install a compatible version of Fetch through UVM’s Software Portal, alongside instructions about the license and how to apply it in the More Info section.

Please click here for instructions on setting up the AppsAnywhere Software Portal on your computer.

Updated on August 28, 2020

Related Articles

Not the solution you were looking for?
Don’t worry we’re here to help!
Submit a Help Ticket