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1. Create the Location form (9:30 – 9:45)
a. Create a form

i. Access 2007 is able to automatically create forms that are often quite close to what is needed.

ii. Click once on tbl_Locations, and then check out the Create… Forms sub-menu.
iii. There are a variety of layouts available.
1. Form: Presents information with the data for a single record next to the field names; will automatically add in a sub-table that is linked to the selected table.
2. Split Form: Presents information with the data for a single record next to the field names at the top of the form, and several rows in a datasheet at the bottom of the form.

3. Multiple Items: Presents information with data for multiple records listed beneath the field names.
4. Datasheet: Similar to “Multiple Items”, with fewer formatting options (basically a spreadsheet).
5. PivotTable: A specialized format that is potentially useful for displaying data summaries.
6. PivotChart: A specialized format that is potentially useful for displaying data summaries.
iv. Try out a couple of layouts to get a feel for what they look like.
v. The “Form” layout is probably the best for our purposes, since we want to display visit and observation data for each site on the same form.

vi. After generating a form using the Form layout, save it as frm_Locations.
b. Examine the new form

i. Does the order of the fields make sense?

ii. Tab through the fields.  Does this tab order work for you?

iii. The percentages have a lot of decimal places, and we may want to modify that.

iv. We can also change how the data is justified.

c. Click into form design view.  The Design menu should be activated, which has a large “Controls” section, and you should also see the Property Sheet to the right side of the form.

d. There are three main sections of the design screen
i. Form Header: Information that will always appear at the top of the form, and that does not contain record-specific information.
ii. Detail: The “meat” of the form, the detail area contains your data records.

iii. Form Footer: Information that will always appear at the bottom of the form, and that does not contain record-specific information.

e. To create a header or footer when one is not visible, hover the cursor just under the header or footer label, until you see a double-headed arrow.  Then click and drag down to create some design space.
f. Properties Dialog

i. Click in different sections of the form, and notice how the Properties box changes.  The contents of this box are context-specific, and vary depending on what type of form object you are working with.
ii. Let’s take a tour of some useful properties.

1. Disable or Lock or Hide a field

a. Sometimes you will have controls on your form that display data only, and that you do not want changed.  Sometimes you need to have a control present, but not visible to the user.  Which option(s) are appropriate here?
b. Disabling a control allows it to be seen, but not clicked in or altered by the user.

i. Click on the Data tab, and set “Enabled” to “No” to disable a control.

c. Locking a control allows a user to click into the field, but not change the data.

i. Click on the Data tab, and set “Locked” to “Yes” to lock a control.

d. Hiding a field prevents a user from even seeing the information, although calculated controls can use the data.

i. Click on the Format tab, and set “Visible” to “No” to hide a control.
e. You can also delete a field, if you do not need it.

i. Right-click on the field itself, and select “Cut”.

2. Selecting multiple controls

a. You can select multiple controls by clicking and dragging a selection box over them.  All of the selected controls will be highlighted with dots at the corners and midpoints.

b. Select the three controls that display habitat information.

3. Decimal Places

a. Change the number of decimal places by selecting the Fixed number format in the Format row of the Format tab
b. Select the number of decimal places using the Decimal Places row.

4. Justification

a. Highlight all of the controls, and choose a text alignment from the Font section of the Design menu, or from the Text Align property on the Format tab.
5. Field Width

a. You can adjust the control width by clicking and dragging on the dots surrounding a selected field, or by using the Width and Height rows of the Format tab.

g. Control order and tab order
i. To change the order of your controls, highlight the controls you want to move and drag them to a new location.  

1. Move the habitat fields below the coordinates.  

ii. Go to form view, and test out your tab order.  You’ll probably find that the “focus” moves to the visit table after the coordinates.

iii. Go back to design view, and right-click in the small box beneath the form name (upper left corner of the form), and select “Tab Order”.  You can rearrange the order here by clicking and dragging to the left of the control names.

iv. You can remove a control from the tab list, or alter the tab order, by selecting the control and using the Tab Stop (whether or not the control can be entered by tabbing) and Tab Index (the order with which controls are cycled through) properties on the Other tab of the Properties dialog.

h. Add a calculated control

i. It might be useful to add a calculated control that totals up the percentages of the different habitat types.

ii. Make the form big enough for a new control.

iii. Method 1:

1. Click on the text box icon in the Toolbox (“AB|”)

2. Click on the form where you want the new field to appear.  Access places the new text box, and gives it a default name.

iv. Method 2:

1. Right-click on an existing control that has the same size and formatting that you want, and select Copy.

2. Right-click on the form, and select Paste.

3. The new control appears at the top-left of the form; drag it to a new location.

v. Change the name to “Hab_Total” by changing the Name property in the Other tab of the Properties dialog.

vi. Also change the name of the label by clicking on the label and setting its name to lbl_Hab_Total.

vii. Now click on the Format tab of the Properties dialog, and change the Caption to something more appropriate.  You can also change the caption by clicking twice on the label text.

viii. Now return to the textbox, and either click on the text that says “Unbound” (or a field name if you used Method 1) or go to the Control Source property on the Data tab.  Type:

1. = forest_percent + grassland_percent + developed_percent
ix. View the results in the Form View.

x. Now change the number of decimal places displayed, and disable the control.
1. On the property sheet, use the Format tab, Format and Decimal Places properties.

2. On the Data tab, set Enabled to No and Locked to Yes.

xi. Set the location of the new control.

1. Move the new control near and beneath the existing column of controls, and highlight all of the controls.

2. Right-click, and choose Layout… Stacked.  The control will be moved under the existing ones.

i. Delete the tbl_Visit view

i. The form automatically added a subform with data from tbl_Visit, but we’ll want a subform that does not look like a table grid.

ii. Right-click in the square that says Table.tbl_Visits, and select Cut.

j. Save and close the table.

2. Create the Visits subform (9:45 – 10:00)

a. Click on tbl_Visits and create a form using Create… Forms… Multiple Items.

b. Save the form as fsub_Visits.

c. Check out the design view, and notice that this layout makes use of the form header to label the fields.

d. Alter the date and time formats, and control justification settings and sizes, if you want.

e. Remove Visit_ID and Location_IDF from the form; this will be a subform, and the Location_IDF will be repeated information, and the Visit_ID is not meaningful to a user of the database.
i. Highlight the fields and right-click them; the remaining fields will move over automatically because the Tabular Layout has been assigned to the fields.
ii. To remove the layout, right-click with one or more fields selected, and choose Layout… Remove.
f. Default View

i. Notice that this form displays lots of records on the screen at once; the last form only displayed one record at a time.

ii. Access the form-level properties (use the drop-down in the Properties dialog, or click in the top-left box of the form).

iii. Change the Default View property on the Format tab to “Single Form” instead of “Continuous Form”, and notice how the form view changes.

iv. How was this property set on the Location form?  What would the “Continuous Form” view look like on the Location form?

v. Return the Default View to “Continuous Form”

g. Extraneous controls

i. Because this will be a sub-form, we can save space by removing some extraneous controls, like the min-max and close buttons.  Find the appropriate properties in the Format tab, and disable them.
h. Clean up form header

i. Clean up the form header by removing the label that says “tbl_Visits” and the picture, then move the field labels up and reduce the size of the header.

ii. Remove the background image, by deleting the text “(image)” in the Picture property.  You can easily add any picture to the header, detail section, or footer of a form using this property.

i. Your subform is now finished!  Go ahead and close it (you’ll need to be in Design view to close it).

3. Add the Visits subform to the Locations form (10:00 – 10:10)

a. Open frm_Locations
b. Expand the design canvas, if needed, to make room for your subform.

c. Click on “Use Control Wizards” (make sure it is highlighted) on the right side of the Design… Controls sub-menu.

d. Click on the subform/subreport icon in the Design… Controls area (bottom left of the group of 18 small icons), and then click on the form.

e. Choose “Use an existing form,” and select the subform and click Next.

f. Access automatically selects the appropriate linking field in this window, so click Next.

g. Accept the default name, and click Finish.

h. Change the title of the subform (label at the top-right of the subform).

i. View the results.

j. Fiddle with the size and shape of the subform window so that all of the data you want to see is displayed.

k. Scroll through the Location records, and notice how the Visit information automatically changes to display only the visits related to that Location.

4. Continue with the Observations subform (10:10 – 10:20)
a. Use Datasheet as the layout for this form (Create… Forms… More Forms… Datasheet).

b. Adjust the format as needed, and notice that this format is less flexible than the others (e.g., can’t change the height of the header row).
i. May want to re-label the headers so that they take up less space, and shrink the columns.

c. Remove extraneous controls (only need Observation ID, Species, Detection Time, and Detection Type).
d. Don’t forget to use the appropriate naming convention: fsub_Observations.

5. Add Observations subform to the Visit subform (10:20 – 10:30)
a. Add the Observations subform to the Visit subform, expanding the design area as needed to make room for the new subform
i. Design… Controls… Subform/Subreport

ii. Notice that Access automatically converts the form to “Single Form” rather than “Continuous”.

b. Open the Location form, and expand the form and subform design areas to accommodate the latest changes.

c. Don’t forget to save all of your design changes.

6. Compact the database

a. When you work with the design of database objects, Access stores temporary objects that take up space in the database file.  You should regularly compact the database to free up space, especially if you are doing a lot of design work.  Some people recommend compacting databases twice, since apparently not all temporary objects are deleted on the first compaction (some are apparently marked for deletion the next time the database is compacted).

b. Compact the database by selecting Office Button… Manage… Compact and Repair.

c. It helps to set the database to automatically compact when it is closed: Office Button… Access Options… Current Database… Application Options… Compact on Close.

7. Verify constraints on data entry and refine the forms (10:30 – 10:40)
a. Open the Location form, and create a new location (click on the right arrow and asterisk icon at the bottom of the form) and enter some data.  Verify that the constraints you have set are functioning.

b. Look for places where data entry can be simplified, particularly with lookups instead of text boxes, and with input masks.
c. Create input masks for Visit_Time and Visit_Date on the Visits subform.

i. In design mode, click in the Visit_Time field, and on the Property Sheet go to the Data tab and click on the ellipses next to Input Mask.
ii. This starts a wizard; select Short Time, and Finish.

iii. Do the same for Visit_Date, selecting the Short Date option.

iv. However, since all the observations were from 2004, it would be nice not to have to type the year.

1. Modify the input mask from: 99/99/0000;;_ to 99/99”/2004”;0;_

2. The 0 between the semicolons tells Access to store what is literally on the screen; putting items between quotes tells access that the items are part of the mask (characters to be displayed), not input mask codes.

d. It would really help to have a lookup for bird codes that auto-completes as you enter observations.

i. In design view, right-click on Species_ID and select “Change to… Combo Box”.  

ii. In the Data tab of the Properties dialog, make sure “Table/Query” is the row source type, and set “tlu_Species” as the row source.

iii. Make sure “Limit to List” is set to “Yes”.

iv. What would you need to do to have the database display the common name and store the species code?

1. On the Format tab of the Properties dialog, change the Column Count to 2, and set appropriate Column Widths; separated by semicolons.  0.6 and 2.0 are about right.

2. Set the List Width to the summed column widths, instead of “Auto”.

e. It would also help to display “Auditory” and “Visual” rather than “A” and “V” for detection types

i. Change to Combo Box, set the Limit to List property.
ii. In the Data tab of the Properties dialog, make sure “Value List” is the row source type, and set “A;Auditory;V;Visual” as the row source.

iii. Change the Column Count to 2, and set the first column to 0”, and the second to 0.7”; set the List Width to 0.7.

8. Delete Test Data

a. Do you remember how to set up cascading deletes?

i. Database Tools… Relationships

ii. Right-Click on each relationship, and select Edit Relationship… Cascade Delete.

iii. Open tbl_Locations, and right-click to the left of the temporary location you entered.

iv. Select Delete Record, and say Yes to the warning.
v. Now go back to the Relationships window and uncheck Cascade Delete in each relationship.

9. About Queries (10:40 – 10:45)

a. In general, you can edit data displayed in a select query, unless that data is summarized (Totals).

b. Joins

i. We’ve already seen some queries where we’ve had multiple tables used in the query.  These tables were linked, or joined, automatically because we have already defined relationships between the tables.

ii. Inner Join: The default join type is an inner join; you only see records from the joined table that match.  
1. This means that “orphan” data that does not match between tables is not displayed.

iii. Outer Join: This type of join shows ALL records from one table, and only the records from the linked table that match.

1. This type of join is a good way to find orphaned data.

2. Another use is for displaying rows of information where the database has no data.  For example, if we had a more complete tbl_Species (i.e., including species that were not detected), we could display a complete Vermont bird list, and how many birds of each species were detected in our study.

10. Select Queries (10:45 – 11:30)
a. You’ve already had an opportunity to create several select queries.  These queries are the most common type, and basically present database records or summaries of records.  Select queries can also be used to perform operations on data, including calculations and conditional expressions.
b. First we’ll do some prep work so we can see how joins work

i. Import the spreadsheet Bird_Codes_VT into a new table, tlu_Bird_Codes_VT.

1. External Data… Import… Excel

2. Make sure to check “First row contains headings” and choose the bird code as the primary key.

ii. Open frm_Locations and add a site 400.A, but do not add a visit or observations.
iii. Click the >* button at the bottom of the form, and immediately start entering observations without assigning a Location or Visit.  Enter 2 observations. Close frm_Locations
c. Look for orphaned data

i. Look for Locations with no visits

1. Create a select query with tbl_Locations and tbl_Visits.
2. Add the primary key from both tables.

3. Change the join type so that all records from tbl_Location are shown.  Notice that the relationship line now has an arrow.

4. View the results; you may need to sort the records to bring the null field to the top of the screen; for site 400.A there is no corresponding Visit record.
5. What would happen if you changed the join type to show all records in tbl_Visit?

a. With an inner join, or an outer join on tbl_Visit, site 400.A does not display.

6. Save the query as qry_Locations_and_Visits

ii. Look for Observations with no visits

1. Create a select query with tbl_Observations and tbl_Visit.

2. Add the primary key from both tables.

3. Change the join type so that all records from tbl_Observations are shown.

4. View the results; you may need to sort the records to bring the null field to the top of the screen; you should find some observations where there is no corresponding Visit record.

5. What would happen if you changed the join type to show all records in tbl_Visit?

a. With an inner join, or an outer join on tbl_Visit, the orphaned records do not display.

6. If you set the criteria for the visit field to “Is Null”, the query will only display orphaned observations.

7. Save the query as qry_Orphaned_Observations

8. Go ahead and delete the new location and the orphaned data.

d. Determine how many individuals were detected at each site

i. What tables do you need? tbl_Location, tbl_Visit, tbl_Observations

ii. What fields do you need? Location_ID and Observation_ID

iii. What else do you need to do?  You want summary information, so click “Totals” (the Sigma icon).  Click the drop-down under Observation_ID where it says “Group by” and select “Count”.  This will then display the number of observations for each site.  Note that there are many other summary options available in the “Total” row of the query.
iv. We are concerned that we may have counted the same individuals multiple times (during different counts).  What is the maximum number of individuals detected during a single count at each site?  This is probably a safer estimate of the bird population at each site.

v. What do we need to change on the query?

vi. First, we need to add the visit (Visit_ID) to the query.  Now our count shows the number of individuals detected during each visit.  How do we pull out just the maximum value?

vii. Unfortunately, you can’t add a second layer of totals to a query.  But you can create a new query based on this one.  Save this query as qry_Individuals_Per_Visit.

viii. Start a new query, based on qry_Individuals_Per_Visit

ix. Add Location_ID and the CountOfObservation_ID field to the query, select Totals, and under Group By for the Count field, select Max.  Verify that this query does what you wanted by comparing the results to qry_Individuals_Per_Visit.  Save the new query as qry_Individuals_Per_Site_Max
x. It is possible to write long chains of queries to accomplish successive total and summarizing tasks.
e. Determine how many species were detected at each site

i. Try this one on your own!  This will also require two queries: one to create a bird species list for each site, then a second to summarize the number of species at each site.

ii. What tables do you need for the first query? tbl_Locations, tbl_Visits, tbl_Observations

iii. What fields do you need? Location_ID, Species_IDF
iv. Then what? Turn on Totals, Group By for both fields.

v. Next, save the query as qry_Species_by_Site and create a new one based on it.

vi. Add both fields to the new query, and select totals, and use Count for Species_ID, and save as qry_Num_Species_by_Site.

f. Calculate descriptive statistics for habitat variables

i. What are the average, min, max, and standard deviation of percent forest at the study locations?

ii. You should be able to do this on your own.

iii. What tables do you need?  Only tbl_Locations.

iv. What fields do you need? Only Forest_Percent, added multiple times.  Note that in this case we want to summarize across all locations, so you do not want to add Location_ID, since this will cause a row to be created for each location.

v. Choose Totals, and select the appropriate summary statistics for the query from the Total row.

vi. Save as qry_Forest_Stats

g. Now calculate the same descriptive statistics for sites where X_Coord is > 475000

i. One approach is to use two queries for this; the first query will select the appropriate sites using a statement in the criteria row of the query design grid (qry_Locations_East), and the second will repeat qry_Forest_Stats, based on qry_Locations_East.  Call this query qry_Forest_Stats_East.
ii. Another approach would use only one query.  In the first column, type “East: iif(X_Coord > 475000, Yes, No)”, and set the criteria to “Yes”.  Then turn on totals, and add Forest_Percent to the query grid several times, and select the appropriate descriptive statistics from the Total row.  The “East” column would stay set to “Group By”.  Save the query as qry_Forest_Stats_East.

h. How different are the results of the two Forest Stats queries?  Create a new query that displays the difference in percent forest between the two queries.

i. Add both queries to the design matrix of a new query, and create a field that calculates the difference: [qry_Forest_Stats_East].[AvgOfForest]-[qry_Forest_Stats].[AvgOfForest]
ii. Note that in this case, the queries don’t need to be linked since there is only one row of information in each.

iii. Call this query qry_Forest_Stats_Average_Difference
i. Create a query that shows how many detections you had of each species that occurs in the state of Vermont (don’t worry about repeat sightings of an individual in different counts).

i. What tables do you need?  tbl_Observations and tlu_Bird_Codes_VT.

ii. What fields do you need? One of the fields from the bird codes table, and Species_IDF from tbl_Observations.

iii. What else do you need to do?

1. Link the tables, using an outer join (i.e., all records from tlu_Bird_Codes_VT).

2. Use Totals, and Count of Species_ID.

iv. Save as qry_Number_of_Detections_by_Species

j. Create a query with complex criteria

i. Criteria for queries can get complicated.  One feature we have not used on the query design grid is the “Or” row.  Actually, all the empty rows below the “Or” on the design grid are for conditional criteria (“Or” statements).

ii. Let’s say that we want to pull out information on locations where certain species were sighted, but for some species we care about which count they were detected during.  For example, we are interested in knowing where all Common Raven sightings are, where American Crows were detected during the second visit, and where Red-Winged Blackbirds were detected during the first visit.  There’s no good biological reason for this query… it just helps to illustrate what is possible.

iii. What tables do you need for this?  tbl_Locations, tbl_Visits, and tbl_Observations

iv. What fields do you need? Location_ID, Species_IDF, Count

v. How do you set up the criteria statements?

1. In the first row of the criteria section, which says “Criteria”, put “CORA” (Common Raven) under Species_ID.

2. In the second row, which says “Or”, put “AMCR” (American Crow) under Species_ID and “2” under Count.

3. In the next row, which has no heading, put “RWBL” (Red-Winged Blackbird) under Species_ID and “1” under Count.

vi. Switch to the datasheet view to verify that this query displays the results we wanted to see.

vii. Save as qry_Complex_Criteria_Example

11. Action Queries (11:30 – 11:35)

a. Action queries are queries that physically change the data stored in tables; select queries never alter the data they are based on.

b. Action queries include Make Table, Append, Update, and Delete queries.

c. It usually helps to begin with a select query, and then convert it to an action query when you are ready to run it.  Among other things, this helps keep you from altering data before you are ready.

d. Note that action queries all support complex criteria and expressions.

12. Make-Table Queries (11:35 – 11:40)

a. A Make-Table query does exactly what it says; it creates a new table in the database based on other information in the database.

b. This type of query is rarely needed in a research database.  The most likely use is to create an intermediate table that can help speed up a series of queries.

c. If you do ever use this type of query to speed up a sequence of queries, make sure you put a mechanism in place so that the table is regularly updated.  This will require re-running the query whenever there is a change to the data that the table is generated from.  Re-running the query will delete the table and recreate it.  This will cause any documentation or changes to the table structure to be lost.

d. An alternative method of storing data in an intermediate table would be to use Append and Delete queries; this will allow you to document the intermediate table, but is a little more complex to keep up to date (it would probably require a macro). 

e. Change one of your queries into a make-table query (go into Design view, then choose Design… Query Type… Make Table).  Enter the new table name, and run the query.

f. Now run it again.  You get a warning, and the old table is deleted before the query runs.

g. Close the query without saving changes, and delete the newly created table.

13. Append Queries (11:40 – 11:45)

a. We’ve already used some append queries as we imported data.

b. Data import is the most common use for this type of query… although sometimes they are used for intermediate processing of long sequences of queries.

14. Update Queries (11:45 – 11:50)

a. Update queries are used to change the values of certain records.

b. We used this type of query earlier to change the Count field of tbl_Raw_Data from “Tape” to “3”.

c. Note that you can change values of one field based on values in another field (as opposed to qry_Update_Count, where we changed the value of the field based on its current value).

15. Delete Queries (11:50 – 11:55)

a. Delete queries are used to remove certain rows (or all rows) from a table.

b. Likely uses for delete queries include removing sample data, removing bad data, and cleaning up tables that store intermediate data from a long series of queries.

c. Let’s say that we have discovered that our observer could not tell Common Ravens from American Crows, and to be safe we want to delete records with these species.

d. We’ll do the deletion on a copy of the Observations table, simply to demonstrate how this would work.

e. Copy tbl_Observations (right-click on it and select Copy, and then right-click and select Paste).  Rename it to tbl_Observations_Copy (right-click and choose Rename).
f. Create and run a delete query to remove observations where Species_ID = CORA or AMCR.  You should find yourself deleting 30 rows from the copy of the table.

g. To delete all rows in a table, simply remove the criteria you have set (you don’t even need to add a field to the query grid), and run the query.  The table should now be empty.

h. Go ahead and delete tbl_Observations_Copy.

16. Parameter Queries (11:55 – 12:05)

a. A parameter query is a query where the system prompts the user for information that will be used to constrain a query’s results or action.

b. Any type of query can be a parameter query.

c. Parameter queries are useful for constraining the results displayed on forms and reports, and on the first day of class we used a parameter query in the Northwind database to constrain the dates for financial reports.

d. To create a parameter query, simply write the message you want to have your users see in the “Criteria” section of the query, under the appropriate field.  Enclose this message in brackets, just like you would enclose a field name.

e. You can use as many parameter statements as you want to refine the criteria for the query.

f. Write a query to display the sites where a species was seen, and ask the user to provide the species code.

i. What tables do you need?  tbl_Locations, tbl_Visits, tbl_Observations

ii. What fields do you need?  Location_ID and Species_IDF
iii. Turn on Totals, and in the Criteria row under Species_ID type: [Enter four character species code:]
g. Note that you don’t have to show all the fields used in this or any other query.  To turn off the display of the species code, click off the “Show” check box on the query grid.

h. Save this query as qry_Parameter_Query_Example

17. Crosstab Queries (12:05 – 12:15)

a. Crosstab queries allow you to calculate and restructure data.  Crosstab queries calculate a sum, average, count, or other type of total for data that is grouped by two types of information – one down the left side of the datasheet and another across the top.

b. We want to generate an index of abundance for each species, based on the number of counts they were heard on.  Then we want to see if there is a tendency for some species to be found or not found in habitat that is predominantly forested.  The basis for this index is a query that lists the location, percent forest, and counts that each species was found on.

i. Create this query, based on tbl_Locations, tbl_Visits, and tbl_Observations.

ii. The fields you need are: Location_ID, Forest_Percent, Species_IDF, and Count.

iii. Turn on Totals, and save this query as qry_Species_by_Location_and_Forest

c. Use qry_Species_by_Location_and_Forest to generate a crosstab query using the crosstab query wizard.

i. Use the Query Wizard (Create… Other… Query Wizard), and select “Crosstab Query Wizard”

ii. Select qry_Species_by_Location_and_Forest from the list of queries, and click Next.

iii. Select Forest_Percent and Location_ID as row headings, and click Next.

iv. Select Species_IDF as the column heading, and click Next.

v. Select Count under “Fields” and Count under “Function,” and click Next.

vi. Name the query xtab_Species_by_Location_and_Forest, and click Finish.

d. View the results and see if you can find any species that seem to be more common in forest habitat, and any species that don’t seem to be common in forest habitat.

e. It may help to “Freeze” the first two columns of the query.  Highlight both columns, then click Format… Freeze Columns.

18. Union Queries (12:15 – 12:25)

a. Union queries will combine information from multiple sources into a unified format.  

b. Union queries are useful for combining similar information from several tables.  For example, in wildlife studies it is common to locate animals in a variety of ways: telemetry, capture, visual sighting, and mortality.  Each of these types of locations has similar data: animal ID, coordinates, date, time, technician; and each also has unique information, such as error polygon size, condition on capture, distance from observer, and cause of death.  A Union query can be used to pull together the information that is common to each table, and the query can also include a new field that references the source of the data.

c. To practice making a union query, we will import some additional bird data (from a different observer), and combine the new data with our existing data.

d. Download and import the file Bird_Data_2.xls into tbl_Raw_Data_2 (the file is on the web site as “Additional Bird Data”.

e. We want our union query to have the following fields: Location_ID, Visit_Date, Visit_Time, Wind, Sky, Species_IDF, and Observer.

f. Note that these fields may have different names in the two sources, but they have the same data types; if the data types differ then you will need to convert the data types so that they match (either “on-the-fly” within the query, or on the source data table(s)).

g. Create a select query based on tbl_Observations, tbl_Visit, and tbl_Location that contains the desired fields.  To create the Observer field go to an empty column and type: Observer: “Wilson”

h. Now create a select query based on tbl_Raw_Data_2, using the matching fields and renaming the field names as needed to match the first query.

i. Type the name of the field in the first query, followed by a colon, followed by the name of the field in tbl_Raw_Data_2.

i. Click View… SQL from the second query, and copy the SQL code.

j. Go to the first query, click View… SQL, and paste the SQL code below the code for the first query.

k. Type “UNION ALL ” in front of the word “SELECT” in the segment you just pasted.

l. Switch to datasheet view to see the results.

m. Save the query as qry_Combined_Data.

n. Note that to combine additional information into this query, you would simply build a new select query that uses the same field names and data types, copy the SQL code and paste it below the existing code, and add “UNION ALL ” before the new “SELECT” statement.

19. Pass-through Queries (12:25 – 12:30)
a. A Pass-through query allows you to execute an SQL statement directly against the tables in an external database.  It is unlikely that you’ll need to use pass-through queries… but just in case, a good tutorial can be found at http://www.techonthenet.com/access/tutorials/passthrough/basics01.php. 

20. Data Definition Queries

a. A Data Definition query is used to create, delete, or alter (add or remove fields or constraints) tables, or to create an index for one or more fields.  This type of query should not be needed unless you are trying to automate complex data management functions using macros or Visual Basic.

21. Useful functions for queries (12:30 – 12:45)

a. There are a number of Visual Basic functions that are helpful and available for use in queries.

b. To get to the Visual Basic function reference, create a blank module and open help from the Visual Basic editor that appears.

c. In the help window, go to Contents… Visual Basic Language Reference… Functions.

d. You can also search for specific functions from the Visual Basic help window.

e. Some useful functions:

i. Mathematical

1. Abs(number) = returns the absolute value of “number”

2. Int(number) = returns the integer portion of “number”; does not round

3. Round(expression, decimals) = rounds “expression” to “decimals” decimal places

a. Create a query based on tbl_Location that creates new fields for percent forest, using the Int and Round functions

ii. Text

1. & = concatenates two strings of text

2. Left(string, length) = returns the left-most “length” characters of “string”

3. Mid(string, start, length) = returns the first “length” characters of “string”, starting at character number “start”

4. Right(string, length) = returns the right-most “length” characters of “string”

a. Extract portions of the observer’s name in tbl_Raw_Data or tbl_Raw_Data_2, and combine them with the Site_Station field.

iii. Conversion

1. CBool(expression) = converts “expression” to true or false

2. CByte(expression) = converts “expression” to number of length byte

3. CDate(expression) = converts “expression” to a date field

4. CDbl(expression) = converts “expression” to number of type double precision

5. CDec(expression) = converts “expression” to number of type decimal

6. CInt(expression) = converts “expression” to number of type integer

7. CLng(expression) = converts “expression” to number of type long integer

8. CSng(expression) = converts “expression” to number of type single precision

9. CStr(expression) = converts “expression” to text

a. Conversion functions are especially useful during data import and export

iv. Other

1. CurrentUser() = returns the current user of the database

2. Date() = returns the system date

3. Now() = returns the system date and time

4. Time() = returns the system time

5. Format(expression, “format”) = format the expression using a named format, e.g., “short date”

6. Iif(expression, truepart, falsepart) = conditional statement, returns truepart if expression is true, falsepart if expression is false

f. Add Date, Now, and Time fields to an existing query.

g. Use the Format function to alter how the dates and times are displayed (note that you can nest functions).  For example, in the query grid, use the following as a field name: Current_Date: format(date(), “Long Date”)

h. CurrentUser, Date, Now, and Time can be useful for keeping track of who makes changes and when changes were most recently made to a table, by using an Update Query via a macro whenever data is changed.


Page 7

